"$" becomes "£" in expansion!

I have a pricing snippet:
${formtext: name=price} + GST = {=price*1.15; format=$.2f}

but when I use it, it now expands like this:
$13 + GST = £14.95

Noting the U.K. pound sign. The expansion has always (for years) worked okay so a bit puzzling. Can someone please try it to see if you get the same result?

The number formatter uses the locale you have specified in Text Blaze. So if you have a locale that uses the pound sign for currency, it will use that when formatting currency.

Note that for the format string in equations, "$" doesn't mean use a "$" sign. It means "use currency formatting" which is locale dependent (and may even add the symbol after the number not before for some locales).

This shouldn't change on its own unless you change your locale either in Text Blaze or for your computer overall. You can change your locale specifically to en-us in Text Blaze to get a $ as your currency sign. You can do this on the options page (click the user icon in the upper right corner of the dashboard).

That did it. Your support is amazing, thank you!