Format clipboard

Hi,

I wish to format the contents of my {clipboard}.

Original:

Text1
Text2
Text3

Formatted:

**Text1** - 

**Text2** -

**Text3** -

I've looked at many of your videos and scoured the Docs page, but i just can't figure it out.

Hi @Mike85 ,
Welcome to Blaze community.

You can apply to bold to the clipboard command directly if you wish to.
If you like a specific format, you can split the text and apply format using {repeat}.

Screen Recording 2024-06-16 at 8.35.50 AM

{list=split({clipboard}, "\n")}{repeat: for item in list}
{=item} -
{endrepeat}

2 Likes

Hi @VinodGubbala ,

Thank you so much for the answer!

I tried using SPLIT, but didn't think to add REPEAT inside. :person_facepalming:

The formatting was just as an example, i'll format the clipboard as needed. Just didn't know how to actually do it.

PS: I can't see where i can mark your answer as solved.

Thanks for the confirmation @Mike85 . I marked it solved now.

1 Like

Hi,

I hope you can help me again.
It starts with a new line (ENTER) except for the last entry.

Mike - Text_Blazw

Can you please share the snippet contents

It's only the snippet you provided, nothing more.
The preview works great, but when i try to use the snippet shortcut it shows just like in the picture.

Can you try in "Try it out" inside the dashboard and let me know the out.
image

Already did, that's how i got the screenshot.
I didn't see it last time, but when i wanted to add data it kept going 1 line lower until the last entry.

Do you get a different result?

yes.
image

If you like to debug further, please send us an email at support@blaze.today so we can schedule a call.

Not sure as to why we have 2 different results using the same snippet.

Mike - Text_Blaze_Dashboard_-_Google_Chrome - (Monday 17-June-2024)

Update!

I've removed that little peace of code and pasted it again. It now works.

Had a similar bug today where a IF would output the result of a dropdown (right under it), but when i recreated it would wait for submission (as it should).

Thank you again for your help!

Glad it works now

1 Like