Bug Report : Extension in Vivaldi/Fedora - Dashboard Link does not work


Running TextBaze Extension in Vivaldi

6.2.3105.48 (Stable channel) stable (64-bit)

and on Fedora 38.

Text Blaze is working great, with the exception of when you click on the Extension Icon, the links in the header don't work.

They simply don't work/do anything when you click on them, unlike the Chrome version.

Not a Major thing but thought I'd log it.

Hey Andy, good to see you back in the forums.

I tried this on Vivaldi (same version) on macOS (13.6) and also on Ubuntu 22.04. (I don't have Fedora at hand).
I opened and closed it a dozen times, and the buttons did fail for me twice. Not only these two buttons, actually, none of the snippet links worked either.

That is a really strange issue. Quick question: does this issue only happen when you have a specific website in the background?

1 Like

Thanks @Gaurang_Tandon , been busy with real life :slight_smile:

For me it happens on most web-pages webpages. Here are a couple for example where it does not work


I could not find one where it was working, although I'm 99.9% sure it's worked at some point.

Happy to provide any more debugging info.

Installed Extensions

GNOME Shell integration
Google Docs Offline

Vivaldi Version Info

Vivaldi 6.2.3105.48 (Stable channel) stable (64-bit)
Revision 1c6fcd98cf165864e5c4ba03424f8512b597f16b
OS Linux
JavaScript V8
User Agent Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36
Command Line /usr/bin/vivaldi-stable --flag-switches-begin --flag-switches-end --desktop-startup-id=fedora;1695304370;248092;3568_TIME30177 --origin-trial-disabled-features=WebGPU --save-page-as-mhtml
Executable Path /opt/vivaldi/vivaldi
Profile Path /home/darkufo/.config/vivaldi/Default

Fedora Info

Linux fedora 6.4.15-200.fc38.x86_64 #1 SMP PREEMPT_DYNAMIC Thu Sep 7 00:25:01 UTC 2023 x86_64 GNU/Linux

Kernal: 6.4.15-200.fc38.x86_64

I'm running KDE Plasma - plasmashell 5.27.8

1 Like

Thanks, I'll take a look. In general, Vivaldi is quite inconsistent with Chrome. For example, it doesn't have the Chrome omnibar code, so the tb<space> keyword trick doesn't work in Vivaldi's address bar (but works in Chrome's address bar)

1 Like