Cedric - Forum message-board errors...and Roam Features

Hi Cedric,
You have messaged me about Roam features in the last week or so. The forum seems to have a bug. I can't read your message. It errors. My default browser is Brave, but I tried Firefox, same error. I also can't read messages I have tried to send, so unsure if they are being sent out. I can read your message through my email as I have email notifications for messages turned on, so that helps.

I'm being a little creative here and sending you a message via the public forums. Feel free to delete this post once you receive it. I still use Roam and Text Blaze. I am a paying user for both and intend on continuing to be. They are both very helpful.

Originally, I wanted to use Text Blaze for templating in Roam. At the time I found there were formatting issues which stopped this from being possible, or made it possible but introduced too much friction. In the end I found using Text Blaze for lots of #[[...]] backlinks helpful and time saving.

If you guys manage to make larger snippets possible and less frictionful (more or less what I am calling "templates") which take into account Roam formatting, I would be very happy! Right now, Roam has introduced a couple of features which makes templating easier, but it is still very frictionful, and requires the use of a mouse.


Hi Tim,

Yes, there seems to be something wrong with the PM feature on the forum. I sent you an email a few days ago and a follow-up yesterday. Could you check your spam folder please?

Can you tell me a bit more about the "friction" issue? Is it coming from Text Blaze or from Roam? Would be great if you could give me some examples.

Thanks :slight_smile:

Your messages arrived in my inbox fine (so no need to search spam folder). The bug occurs when I click to open the message. A page is loaded with the following text:

"Sorry, we couldn't load that topic, possibly due to a connection problem. Please try again. If the problem persists, let us know"

I did send you a reply to the first message five days ago, and the second message 11 hours ago. FWIW, I receive the same error message if I now try to read my own messages in the Sent Folder.

As to friction:
It has been a month or two since I tried setting up more complicated templates so my memory is fuzzy. But I believe I came across trouble when trying the snippet below:

Keywords: #Projects
{key:enter}{key:enter}Due Date:

The second line is intended to be a new bullet point indented one level under the parent. Instead, it creates a newline while staying in the same block, equivalent to "Shift+Enter" in Roam. More generally, I found this occurs whenever the line had the "#name" at the end. Inserting text after "#name" creates a different problem where the double key:enter doesn't indent.

It would also be awesome if there were a way to have a snippet formatted to one of the three header options available in Roam (H1, H2, or H3).


About the emails, I'm talking about an actual email sent through my email address, not a notification sent through the forum PM. Please look for the email as I need to discuss something with you and I don't want to clutter the forums.

As for the fresh line issue, yes, we're aware of it, and we're already working on a functionality to address it and make it super simple :slight_smile:

In the meantime, here's how you can do it "manually":

Keywords: #Projects
{key:enter}{key:enter}{key:tab}Due Date:

As for using headers, here's how you do it:

Heading 1: #Projects {key:ctrl-alt-1; trim=yes}
{key:enter; trim=yes}
{key: tab; trim=yes}indented heading 2
{key:ctrl-alt-2; trim=yes}
{key: enter; trim=yes}
{key: shift-tab; trim=yes}
not indented

IMPORTANT: When you're using hashtags on the final word of a line, always put a space afterwards and then put the trim command inside the {key: enter} command to remove the extra space. Otherwise it won't work properly.