Hubspot chat and email: missing empty lines

Hi :slight_smile:

Is there any way to keep empty lines?

Empty lines in Text Blaze is being removed when used in the Hubspot inbox. I figure this is just how Hubspot formats the text, since it works perfectly in Gmail and other places.

Snippet in Text Blaze:

Snippet in Hubspot:

I wrote some new snippets today and I saw that the empty lines is being kept if you use bold text.

Snippet in Text Blaze:

Snippet in Hubspot:

This one works perfectly as well, due to the bold text:

Snippet in Text Blaze:

Snippet in Hubspot:

If you remove the bold text, the empty lines disappear again.

The previous snippet without bold in Text Blaze:

The previous snippet without bold in Hubspot:

Is there any way at all to "force" Hubspot to add the text just like you wrote it in Text Blaze, keeping all empty lines? Without having to make the text bold that is.

Text Blaze is such a huge time saver and it's frustrating that Hubspot forces you to manually add these empty lines back. But maybe there's an easy fix that I have missed.

Any ideas? :slight_smile:

Hi Welcome to the forum! :slight_smile:

Thanks for the helpful screenshots. I did not know about this issue in Hubspot before, but I have noted it down to fix in the future. Has this started happening recently? Or it's been like this since you started using Text Blaze?

In the meanwhile, to force the newlines, open the snippet in Text Blaze, and then: 1. select any whitespace in your snippet 2. make it bold or italics. Let me know if it works for you.

Hi @Gaurang_Tandon.

Thanks a lot for the quick reply! :smiley:

No worries. A fix would be fantastic!

It actually worked only having to click the space bar once on the empty line, leaving one invisible character. There was no need to add bold on the empty line.

Thanks a lot for helping me with a solution. That's a relief.

I have actually used Text Blaze with Hubspot since 2021, through a different account and it's always been this way. I have always added these empty lines manually, thinking that's just how Hubspot formatted the text when adding it in.

I could have saved a lot of time through the years with this simple click of the space bar. Absolutely fantastic to find a temporarily solution now though!

Thanks again :smiley:

Glad it works.

Wow your patience is amazing. I should fix this issue soon :sweat_smile:

Just to confirm, are you seeing this issue on all textboxes in HubSpot? In my case, I am trying this in the "Note" textbox, specifically here:<id>/contact/<id>?interaction=note.

Hard to complain about one small thing when 1000 others work perfectly :blush:

Tried your link, but it wouldn't work on my end. From the link, I believe you went into a contact and tried to add a note. Tried it now and it worked the same exact way. No empty line spaces showed up, but they did if I made an invisible character with the space bar on each empty line.

Noted. I will take a look at this issue.

1 Like

Any Update / fix on this?
I have the same issue with Hubspot and Chrome Addon.

Hi @Ralf Welcome to the forum! :slight_smile: Sadly no update on this issue yet.

Hey @Gaurang_Tandon, thanks for the Welcome.

Okay thats very sad, because the Solution not work for me. And we need that Text Expander for Work with Hubspot in our Company.

I figure out that i only can get a Solution if i use the Keyboard: Enter function. Without any Spaces or something. And that makes it really hard to generate Snippets.

okay :slight_smile: i am getting a solution.
if i copy a text into Textblaze, i need to "Delete Formatting" and than it works.

1 Like