Moving the cursor around

I have a snippet for doing the following (in Gmail). When I receive certain emails, I want to forward them to specific address, and add something to the subject line also (while keeping the existing subject).

First I press forward and then in the address box in Gmail I type my snippet shortcut.
It enters the address I want in the box (this works fine)
Then it presses shift tab a few times and Enter to get me to the Subject line
Then it presses left arrow to position the cursor at the start of the subject line.

The purpose is to place the cursor at the start of the subject line so I can type something there, or run another snippet there.

It was working fine, but now I've added an If function to my snippet. The reason I did this is because I have to press Shift Tab a different number of times if there is more than one recipient to the original email.

Now when I run the snippet, it does everything correct, but at the very end when the cursor is at the start of the subject line, it moves the cursor one step to the right. I can't work out why this is or how to stop it.

That's interesting. I don't think adding an {if} command shouldn't change anything here. Would you be able to share your snippet here so we could take a look at it?

Thanks Scott,

This is it:

{formmenu: name=client;
{note}{formtoggle: name=dd; default=yes}{endnote}
{if: dd=="yes"}{key:shift-tab}{key:shift-tab}{key:shift-tab}{key:shift-tab}{key:downarrow}{key:downarrow}{key:downarrow}{key:enter}{wait}{key:leftarrow}{else}{key:shift-tab}{key:shift-tab}{key:shift-tab}{key:shift-tab}{key:downarrow}{key:downarrow}{key:downarrow}{key:downarrow}{key:enter}{wait}{key:leftarrow}{endif}

I've tested it and it actually seems to work great for me when I did it.

Possibly you have an extra space or something that was added as part of adding the {if} statement? Can you test the snippet exactly as it is written in your post above? (I formatted the snippet section of your post above a bit so it may be slightly different from what is actually in your original snippet).

Thanks Scott, that seems to be working perfectly now.

Hi Scott,

I added another line to my options list (see below) and now the original problem has reoccurred. Have you any idea what could be causing this. I tried removing the line and re-adding it, also removing and adding the space at the end of the word, adding the line using either the enter key or the Shift+Enter key but nothing works.

Any thoughts?

shane82shelter+ { formmenu: name=client;








trim=yes }

{ note } { formtoggle: name=dd; default=yes } { endnote }

{ if: dd=="yes" } { key:shift-tab } { key:shift-tab } { key:shift-tab } { key:shift-tab } { key:downarrow } { key:downarrow } { key:downarrow } { key:enter } { wait } { key:leftarrow } { else } { key:shift-tab } { key:shift-tab } { key:shift-tab } { key:shift-tab } { key:downarrow } { key:downarrow } { key:downarrow } { key:downarrow } { key:enter } { wait } { key:leftarrow } { endif }

Possibly you are adding styling to your snippet when you modify it. A styled snippet can have subtle differences in behavior compared to a plain text snippet.

Can you try removing all styling by selecting all the text and clicking the "Tx" icon in the formatting bar?