Open as administrator on startup

Hi, is there a way to Run As Administrator on startup on Windows 10?
I have the Desktop app set to open on startup, but it doesn't, and clicking on the app in Start won;t run, I have to right-click and select Run As Administrator.
What did I miss?

Hi @andrew1,

Welcome to the forum :slightly_smiling_face:

Actually, by default, the Text Blaze Windows app doesn't start in admin mode, but you can set it to run as admin by default using the following steps:

  • Right-click the application's Shortcut
  • Go to Properties
  • Click the Advanced button on the Shortcut tab
  • Check the "Run as administrator" box
  • Click OK

It is disabled...

Hi @Josem,

This can be because you might have UAC disabled on Windows. You can enable it by following the instructions here. Please let me know if you have any questions.

I have tried (restarting) with the highest and lowest level with the same result.

I'm afraid the problem has to be that it's a Windows App. I have taken the link from shell:AppsFolder

Hi @Josem,

Please follow the given path and set the executable to 'Run this program as an administrator' in Properties > Compatibility. Here is the path if you have installed the app from MS Store: C:\Program Files\WindowsApps\BlazeToday...\app\Text Blaze BETA.exe. If you have installed the app directly from the Text Blaze website, then setting the .exe to run as admin will stop the app from autostarting.
Note: Some folders in the path might be hidden so first unhide all the hidden folders.

Not only hidden... I have been looking at the possible ways to make changes in C:\Program Files\WindowsApps and the implications that can be derived from these changes can make me lose a lot of time that I do not have.
Thank you very much for the help but for now I will have to continue starting "Run as Administrator" by hand

We are sorry for the inconvenience caused. Our list of features includes “auto start as administrator” and we plan to release this feature soon. Rest assured, I will notify you once it is available for use.



As far I know, it seems that with the auto-start improvements of v1.4.2 it has been resolved. At least I no longer get errors about not being able to run TB as administrator.

1 Like