Snippet shortcut not clearing on Figma Web

I am having the exact same problem: trigger won't disappear when using in Figma. It seems to be working correctly on everything I've tried except for Figma.

Edit: I should add that this ONLY applies to the text field component (as in the design feature added to a canvas to add text). An in-app search field or any other actual text input for the app itself works fine.

I understand this may be an issue with the way Figma is made, and maybe can't be fixed by Text Blaze, but I thought I'd bring it up

Hi @Michael_Caldwell Welcome to the forum! :slight_smile:

Are you referring to this Text component on Figma? (denoted by the T icon in the bottom)


I just tested shortcut deletion for both plain snippets and form snippets in this text field, and it works fine for me. Can you check by disabling other extensions you might have in your browser, and reload the Figma page, and then try again?

Hi @Gaurang_Tandon I'm using the web version of Figma and have the same experience as Michael. When trying to use a Text Blaze shortcut in a text box, the shortcut is not replaced by the text.

I've tried inserting a delay, but that didn't work.

Do you have any suggestions that we could use to delete the shortcut after the text has been inserted? Is it possible that Text Blaze sees the Figma text box as a text field (which apparently requires the Text Blaze Pro subscription)?


Thanks, I am able to reproduce the issue today. It looks like Figma might have incrementally rolling out this update. We will work on a fix asap and keep this thread updated.

1 Like

Hi @cblocher and @Michael_Caldwell
The fix is now available in the beta version of the extension. It will be in the public version after a week. If you require the fix earlier, please email me at and I'll setup the beta access for you.

1 Like

Hi all! The fix for this is now available in the public Text Blaze extension (v3.1.1). You can reinstall the extension if you don't have the version yet. Thanks again for reporting the issue!