Up and Down Arrow Keys

What an amazing tool text blaze is I must say. The kind of time you can save with it is just marvelous, not to mention its satisfying automated live filling-in the text fields. Just like a magic show.

Anyhow I was experimenting some snippets and was looking to use arrow keys - specifically up and down arrow keys to "scroll" through a list and select a specific item from that list. To my surprise I found out textblaze doesn't support up and down keys. Could use some ideas on how to tackle such situation; and if doing so is even possible. Thanks!

Hi, and welcome to the forum! :slight_smile:

You can try using: {key: uparrow} and {key: downarrow}

However, please note Text Blaze arrow keys are simulated. We try to replicate what would happen if you actually pressed the up or down arrows, but it may not work in the specific app/situation you are using them in.

1 Like

Thank you for that. Works as I had intended it to.

Hello everybody! I'm trying to use {key: downarrow} but it`s not working. Could you help me? Is this feature still working?

1 Like

Hello @Vinicius_Almeida! Welcome to the community! Glad to help you. Tell me how you are trying to use the arrow keys, what platform, software or website you are trying to use them on, etc. We'll figure this out together!

Happy Blazing,

Thanks for your answer!
Unfortunately it is a private software I’m using, so you cannot access
But I can put some printscreens later

Basically, it is a text input that, when I type something, another container (a group focus or something like that) appears beneath it with some options to select. It’s kind of a dropdown. And to focus on the options I need to use either the arrow keys or the mouse. And to select I use the click ou enter key.

I’m using a MacBook. I don’t know if that changes something.

I tried to reproduce that sequence of key strokes using {key: downarrow}
I tried to add some wait to let the list of options to load, but nothing worked.

Really need your expertise with it.

1 Like

Thanks for the fast response! Yes - screenshots would be tremendously helpful. If all else fails, we can jump on a Zoom or Google Meet in the next few days to see if we can get this working the way you wish. Have a nice evening!

This is part of the form. I want to use a snippet in that input box.

When I click on it, those options appear and they are filtered by what I write.

After I write the option I want, there is no key stroke that selects the first one. I need to focus somehow on the option I want. To do that either I use down arrow or the mouse.

This is how it looks when I press down arrow. After that, an enter solves the problem and I can go on filling up the rest.

That's the final result. It doesn't work if I write exactly the name of the option I want and then press tab. This doesn't select the option and the input remains without value assigned.

This is the snippet I created to test if it was possible to use text blaze to speed up this part of my job.
It would be so nice if I could do it. So much would be done by snippets.

I hope I gave enough information to solve this. I really don't know what more i can test

I tested also the behavior of uparrow and downarrow inside a multiline text box to see if the text selector moves with those commands and basically nothing happens.

Hello @Vinicius_Almeida, Thanks for reporting. We are looking into it. Could you please try this meanwhile?

Hemograma com Plaqueta{key:s}{key:tab}{key:downarrow}{key:enter}

Notice that the last character in your search string is passed as {key:s}

1 Like

I agree with @aditya! This solution may not be ideal, but it likely will work. I have to do something similar in Salesforce from time to time.

Maybe another approach to this could be to simulate the space bar keystroke after Hemograma com Plaquetas. At least then your entire string of text is entered. Or, perhaps simulate a {click} after the string then the tab & down arrow keys.

Or, another thought. As you type and the results appear in the list, can you arrow down without pressing the tab key first? If so, you may be able to simulate the first few keys if the string, then simulate the down arrow keys to reach the item you want to select…then simulate the enter key. This works in similar fields within Salesforce so it may work here for you?!

Again - happy to jump on a screen share with you if you’d like. If not, that’s cool too.


Here's an alternative to test.

Instead of typing the shortcut in the text box, use the keyboard shortcut for Text Blaze to open the extension menu. The keyboard should be ctrl+shift+space.

When the extension menu opens, start typing your shortcut (this will be typed in the extension menu, not in your text box), and then press enter, which will insert your snippet text.

To understand better, I recommend you watch this video before trying it out:

I'm hoping that by avoiding to write the shortcut in the text field, the dropdown menu will match the text immediately without any confusion. Again, not sure whether this will help, but it's worth testing.

Let me know.

1 Like

Hi! I'm also trying to choose an option from a dropdown menu and whatever I try, it doesn't work. I've tried all the options above. This is the menu:

Any ideas? :blush:

Ah sorry, just to clarify: I need to select "percentage", type "100" for the discount value, and type the word "replacement" in the third box.

1 Like

Hi @Monica_Scholte and welcome to the forum.
In which text box do you trigger the snippet? It may make sense to start from the end and trigger it in the 3rd text box. Something along the lines of (you'll have to test how many shift-tabs are actually required to move between fields:

replacement{key: shift-tab}{key: shift-tab}100{key: shift-tab}{click}{key: downarrow}{click}

Hi @Dan_Barak1, thank you!

Yes I was triggering it in the third box, I tried your snippet, but sadly it does not work, the box just does not move.
If I manually do it, it would be the following:

Two shift-tabs
"p" OR down arrow

Things I tried that also do not work:
replacement{key: shift-tab}100{key: shift-tab}{click}{key: downarrow}{key: enter}
replacement{key: shift-tab}100{key: shift-tab}{key: downarrow}{key: enter}
replacement{key: shift-tab}100{key: shift-tab}{key: p}{key: enter}

Whatever I try, it fills out the third and second box correctly, but then only selects the dropdown box and doesn't seem to do anything.

Any other ideas? :blush: I appreciate your input!

Unfortunately if this didn't work there's probably no way to trigger downarrow/uparrow. As you'll see in the posts above (specifically Up and Down Arrow Keys - #2 by scott), uparrow/downarrow are not guaranteed to work on all websites. I can suggest a different approach:

replacement{key: shift-tab}100{key: shift-tab}{wait:delay=+5s}{key:enter}

You can add a wait command in place of the downarrow. Then, when the cursor has moved to the menu, you can press downarrow yourself during that 5 second delay.

I understand this is not what you're looking for, but our extension is constrained by the rules of the browser, so this is the clearest workaround there is so far.

1 Like

Thank you so much, that is a great alternative, and it will still save my co-workers and me a lot of time :blush:


Hi everyone! I am happy to share that selecting options from a list - using up arrow and downarrow - is now supported in the extension! Now you can use {key:tab} and {key:downarrow} (or {key:uparrow}) to select an option in a dropdown list, and in checkbox buttons/radio groups as well.

Try it out and let me know if you face any issues.