Whitespace disappears, but only when formatted?


I use Text Blaze for transcription and have a snippet to quickly enter the speaker, formatted like so:

Speaker: Ambiguous text here.

That is, "Speaker:" is bolded, and the text I would type afterwards is not. So I have formatted my snippet as "Speaker:" in bold, followed by an unformatted whitespace.

Strangely, when I use this snippet, my whitespace disappears, and my format stays bold.
I have tried removing any formatting from my snippet, and my whitespace returns.

I have tried bolding the whole snippet (whitespace included) and the whitespace disappears again. The same holds true for italics, underline, and strike-through. I have seen that there's a trim setting for forms, is there some way to force my whitespace to stay with just text?


Hi @Izzy, welcome to the forum.

The issue here is that Text Blaze collapses whitespace when it's used this way. I'll bring up the issue with the tech team.

In the meantime, here are two quick workarounds.

The first one adds an unformatted period after the space, so anything you write after that will also be un-bolded

Speaker: .

In the second one, the colon is unbolded, so anything you write after that will also be un-bolded.


Hope this helps, at least until we work on the issue :slight_smile:

1 Like

Hi! You could also try adding an unbolded letter in where you want the space but change it's color to match what you're putting the text into. It of course would depend on whether or not it allows for colored text.

1 Like