Zapier connection issues

I can't get Zapier to pull data from Data Blaze.

I have connected the account using the API key and the connection tests as successful.
I have two rows of data in Data Blaze
I have cleared my Chrome cache for both Zapier and Data Blaze
I took the table id from Data Blaze Dashboard ID**/view/0ijuJLDAccr3p1xfMrd556/
When I try to test the trigger, no rows are found.

Any suggestions?

Hey Jonathan, welcome to the community :tada:

Please keep in mind that the table ID is the string of text after 'table/' in the table url.

Here's an example url:

https: //

The table ID for this table is 6v4JcxLVkCaYq8Axb71vL2.

Does that help? Please let me know if you have questions and if that helps you get it set up.

Here's a video that walks through the setup:

Thanks very much. Yes, that's how I'm grabbing the table URL and it's still not working.

Can you check your API token from Data Blaze to make sure you have 'Read' selected in the API token menu?

By not working, do you mean that the rows do not show up when you click 'Test Trigger' in Zapier? If that is the case, can you double check that you have given Zapier access to your Data Blaze account? There should be a pop-up asking you to give access.

Or do you mean that the action step isn't working? If that is the case, please check Zapier and see if there is an isuse with the action step you've set up.

@Jonathan_Burns As you're testing the row created event, this trigger will fetch only the recent rows, can you please try to add a new row first, and then immediately test the trigger again?

I did. Still no rows pulling in.
2024-05-17 at 12.35.36 PM

@Jonathan_Burns Can we have a quick call? I sent you a direct message about it.

Thanks for the nice call, @Jonathan_Burns, as a reference, it's fixed by correctly adding a new row to the table before testing it.

1 Like