Force Formating

Hello everyone
I would like to force formating.
If I have a bold text in the clipboard it is pasted bold. Is any way to force some custom formating?

We are using Systemwide this formating.

1 Like

Hi @Dmitrij_Moreinis,

That depends on whether formatting is accepted in the platform where you're inserting your snippet. You can definitely apply formatting inside your snippets in the dashboard.

I don't understand the part below:

Could you clarify please?

I am getting really frustrated with the bold feature of Text Blaze. When I bold something, the bold does not turn off at all. What am I doing wrong? In Dashboard it looks fine. But when it pastes into Gmail, once it gets to the first bold the rest of the email will be bold.

Hi @Bernabe_Garcia, welcome to the forum. Sorry to hear you're experiencing issues.

What you're describing is unusual. As you can see below, it works fine for me.


May I ask you to share your snippet with me please by using the "Share snippet" button at the bottom left of your snippet window? Please make sure you replace any confidential text.

Same here.

I can dublicate this.

not bold
not bold

when copied from Text Blaze snippet to other Text Blaze snippet everything is bold.

Also the links are not beeing copied.

Dear Cedric,

Here is one of the snippets that I was having trouble with. I found a work around, which I have deleted and reverted for purpose of showing the issue.

The issue I found is that when any snippet command/formula immediately follows formatted text, the rest of the snippet will continue to apply the format of that text.

The only way that I can get around this is to insert punctuation (in the first instance I had to insert a colon (":") after my first heading "Course Overview." I also have to make sure the colon is not formatted. I do not want a colon there, but because of line break issues I need the {key:enter} command there instead of a carriage return (I also use the snippet in Odysseyware and Gmail and both handle it differently).

I had punctuation after each heading, but took them off so that you can see the issue with the snippet.
The second heading "Unit Synopsis" was working because I endured the extra spacing, and put a carriage return instead of the {key:enter} command. I reverted to using the key enter command because I wanted you to see the issue.

As long as there is unformatted text between the formatted text and the {command} there is no issue. Note: Spaces do not help because Text Blaze continually trims spaces that the program considers "unimportant." It will work the first time (as in if you make a correction in the snippet and then text it). But once you navigate away from the snippet in Text Blaze, the program trims the blank spaces and you are back to uncontrollable formatting.

Note: even within quote marks, Text Blaze continues to trim blank spaces making lining up numbers on a column impossible -- I was forced to use [option] + [space] to hard space in order to line up numbers on a decimal point.

Also, once it starts to run away, no further forcing formats seem to make any difference...

Looking forward to some answers...

Interesting, thanks for digging into this Bernabe. Very helpful!

I am seeing the issue when following the bolded text with a {key} command like in your example. But I am seeing it when following the bolded text with a formula {=} or with a {time} command. Are you seeing it with commands other than {key}?

Also, and this is just for your specific case not for the general bug. Do you really need the {key: enter}'s? Can you not just replace them with actual newlines in the snippet which won't have this issue?

If I want to keep the text of my new line directly underneath my heading, I have to use the {key:enter} otherwise Odysseyware automatically double spaces to separate paragraphs. I have not been able to turn that function off in Odysseyware.

If I paste into a Google Doc, then I can get away with just a newline and it will go right underneath my header. Same thing in Gmail. But in Odyyseyware a new line gives me a double space.

Since I use the snippets in all three programs, I have to include a {if:SentAs=="Gmail Message"}{key:enter}{endif} (in addition to a new line) when I do want to double space while I just use a new line in Odysseyware... This is not the only issue with Odysseyware... Odysseyware does not bring any of my formatting in... Not even on a copy and paste. But, that is a bug for them, not for you... LOL.

@Bernabe_Garcia, try this for line breaks:

{="\n"; trim=yes}

some text
{="\n"; trim=yes}
some text


I've done some more digging. Here's what I've found:

This presents the issue you've reported.

[formatted text]{key:enter}[non-formatted text]

This does not present the issue.

[formatted text]{="\n"}[non-formatted text]

This does not present the issue either.

[formatted text]
{="\n"; trim=yes}
[non-formatted text]

Of course, we'll still look into it. But for the line-break issue you're experiencing on Odysseyware I think the command {="\n"; trim=yes} could be a good workaround.

By the way, the "\n" represents a line-break. I'm using trim to eliminate the extra line-breaks I created for the purpose of easy-reading.

In other words, this would give the exact results but would look cluttered:

[formatted text]{="\n"}[non-formatted text]

This would give me too many line-breaks:

[formatted text]
[non-formatted text]

That is Awesome!
Thank you, so much. That trim snippet will work wonderful for me. For visually separating lines of thoughts, I had been using {note}
{endnote} But I think the {="/n"} is much easier/faster.
Thanks for taking the time to help me with a work around that not only helps me with my issues but also makes me a better all around user.
I have some pretty cool stuff I am building with Text Blaze... I especially like being able to create long Google Sheets formulas that I use often for building complex pages.
Everyone is wondering how I can create my Sheets so fast... LOL

I'm glad you've found this useful :slight_smile:

Careful though:

It should be a backslash \, not a forward-slash. Otherwise it won't work!